【安全公告:UTSA-2023-000166】-【CVE-2021-29458】

发布日期:2023-01-19

基本信息

漏洞编号: CVE-2021-29458

受影响系统版本: 服务器D版

受影响源码包: exiv2

修复版本: 0.25.8-deepin1

CWE编号: CWE-125

漏洞等级: 中危

CVSS_v3评分: 5.5

漏洞描述

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.

修复方式

sudo apt update && sudo apt dist-upgrade

是否受影响判断

判断方法:apt policy PackageName
结果说明:版本小于修复版本,则受此漏洞影响,版本大于等于修复版本,则此漏洞已修复。

补丁链接

暂无